易语言隐藏组件纵向垂直滚动条

小泽 2020-06-08 09:17 1条评论

易语言隐藏组件纵向垂直滚动条,如超级编辑框,高级表格,编辑框等

DLL:

.版本 2

.DLL命令 FlatSB_ShowScrollBar, 整数型, "comctl32"
    .参数 hwnd, 整数型
    .参数 code, 整数型, , 0=水平,1=垂直,3=垂直+水平
    .参数 fShow, 整数型, , 0=隐藏,1=显示

.DLL命令 ShowScrollBar, 整数型, , "ShowScrollBar"
    .参数 句柄, 整数型
    .参数 类型, 整数型, , 0=水平,1=垂直,3=垂直+水平
    .参数 与否, 逻辑型, , 假=隐藏,真=显示

.DLL命令 CallWindowProcA, 整数型, , "CallWindowProcA"
    .参数 程序指针, 子程序指针
    .参数 窗口句柄, 整数型
    .参数 消息, 整数型
    .参数 参数1, 整数型
    .参数 参数2, 整数型

.DLL命令 SetWindowLongA, 子程序指针, , "SetWindowLongA"
    .参数 窗口句柄, 整数型
    .参数 要置的特征, 整数型
    .参数 新特征, 子程序指针, , 仅易语言3.0支持

变量:

.版本 2

.程序集变量 默认窗口, 子程序指针

源码:

.版本 2


FlatSB_ShowScrollBar (超级编辑框2.取窗口句柄 (), 3, 0)

默认窗口 = SetWindowLongA (超级编辑框2.取窗口句柄 (), -4, &处理)

.版本 2


.子程序 处理, 整数型, , 该子程序为近在眼前后加的

.参数 句柄, 整数型

.参数 消息, 整数型

.参数 参数1, 整数型

.参数 参数2, 整数型


.如果真 (消息 = 131 或 消息 = 15)

    ShowScrollBar (超级编辑框2.取窗口句柄 (), 3, 假)  ' 1=隐藏纵向滚动条,2=隐藏横向滚动条,3=全部隐藏

.如果真结束

返回 (CallWindowProcA (默认窗口, 句柄, 消息, 参数1, 参数2))



本文标签: 易语言, 隐藏, 滚动条
0.0

说点什么吧
  • 全部评论(0