易语言窗口靠边自动收缩隐藏 上下左右都行

小泽 2020-05-08 11:02 1条评论

20191111195029302.jpg

.版本 2

.如果 (取鼠标垂直位置 () > 顶边 - 2 且 取鼠标垂直位置 () < 顶边 + 10 + 高度)
    .如果真 (顶边 ≤ 0)
        顶边 = 0
    .如果真结束

.否则
    .如果真 (顶边 ≤ 0)
        顶边 = -高度 + 2
    .如果真结束

.如果结束
.如果 (取鼠标水平位置 () > 左边 - 2 且 取鼠标水平位置 () < 左边 + 10 + 宽度)
    .如果真 (左边 ≤ 0)
        左边 = 0
    .如果真结束

.否则
    .如果真 (左边 ≤ 0)
        左边 = -宽度
    .如果真结束

.如果结束

.如果 (取鼠标水平位置 () > 左边 - 10 且 取鼠标水平位置 () < 左边 + 2 + 宽度)
    .如果真 (取屏幕宽度 () - 左边 - 宽度 ≤ 0)
        左边 = 取屏幕宽度 () - 宽度
    .如果真结束

.否则
    .如果真 (取屏幕宽度 () - 左边 - 宽度 ≤ 0)
        左边 = 取屏幕宽度 () - 2
    .如果真结束

.如果结束
.如果 (取鼠标垂直位置 () > 顶边 - 10 且 取鼠标垂直位置 () < 顶边 + 高度 + 32)
    .如果真 (取屏幕高度 () - 顶边 - 高度 - 30 ≤ 0)
        顶边 = 取屏幕高度 () - 高度 - 30
    .如果真结束

.否则
    .如果真 (顶边 = 取屏幕高度 () - 高度 - 30)
        顶边 = 取屏幕高度 () - 2


本文标签: 易语言窗口靠边收缩, 窗口自动收缩隐藏
相关文章
0.0

说点什么吧
  • 全部评论(0